Record start

GoldWave general discussions and community help

Record start

Postby blindogg » Fri Feb 02, 2018 10:40 am

My computer did some updates while I had GW open and now I can't start a recording (loopback) unless the source is playing. It wasn't like that before the update/restart...I know it's a simple setting change but I can't figure it out.
Help!
blindogg
 
Posts: 2
Joined: Fri Feb 02, 2018 10:34 am

Re: Record start

Postby 2leftfeet » Fri Feb 02, 2018 4:09 pm

Open Goldwave, hit F11 and select "Devices" In the Record section of the window, select "Loopback Speakers" and whatever quality settings you were using. (I use the 44100/2/32 and shared setting).
Perhaps re-installing is another option. To avoid PC updates messing things up, go into your PC "updates and security" window and choose to "notify me when to install updates" and choose when to receive updates or the "metered broadband option". Plenty of people have issues with updates messing things up. Maybe someone else has more suggestions. I have never had any issues with Goldwave or anything else since I have been choosing when I want to install Windows updates, I close any programs I am using and then just let the update service run.
2leftfeet
 
Posts: 83
Joined: Sun Jan 20, 2013 9:58 pm
Location: Napier New Zealand

Re: Record start

Postby blindogg » Fri Feb 02, 2018 4:23 pm

Thank you - I'll give it a try!
blindogg
 
Posts: 2
Joined: Fri Feb 02, 2018 10:34 am

Re: Record start

Postby DougDbug » Fri Feb 02, 2018 4:55 pm

Something may have changed with the Windows update...

I don't know of a good solution.

I was reading about similar problems and when I was searching around I found this on a Microsoft programming website:
Another oddity is that WASAPI will only push data down to the render endpoint when there are active streams. When nothing is playing, there is nothing to capture.
One of their solutions was to "play silence", and I suppose that's easy if you're a programmer... (I wasn't looking for a programming-related website, it's just what Google found.)

Or, you could try generating a silent file in GoldWave and then play it back in Windows Media player while recording. But even if that works, it would be a pain and multitasking while recording can sometimes cause "issues".

Another proposed solution I found was to open an unused audio input/recording device in Windows Control Panel and select "Listen to this device". But, you'd need an unused input and you might still get some electrical noise. And the computer I'm on right now won't allow me to enable a microphone-input or line-input because nothing is plugged-in.
DougDbug
 
Posts: 1985
Joined: Wed Feb 16, 2005 3:03 pm
Location: Silicon Valley

Re: Record start

Postby GoldWave Inc. » Fri Feb 23, 2018 8:44 am

The sound driver may have been updated. Some drivers pause LOOPBACK recording when nothing is playing. You could create a silent file in GoldWave and enable looped playback to play it continuously so that the LOOPBACK recording device has a continuous stream to record.
User avatar
GoldWave Inc.
Site Admin
 
Posts: 3773
Joined: Wed Mar 10, 2004 6:13 pm
Location: St. John's, NL


Return to GoldWave General

Who is online

Users browsing this forum: No registered users and 1 guest

Google Ads

Keywords: sound editor, song editor, audio editor, sound converter, sound recorder, itunes, mp3, cassette, tape recording software, vinyl, LP, restoration, noise reduction, clean, filter, visual, speech