file formats

GoldWave general discussions and community help
Post Reply
arepSA
Posts: 5
Joined: Wed Jul 04, 2007 1:58 am

file formats

Post by arepSA »

Hi.

I was trying to concatenate 9 .wav files into a single RAW file( ext is still .wav)

The file format options settings are as follows:
ext: .wav
type: RAW
rate: 22050
attribute: PCM signed 16 bit, big endian, mono.

After I opened the single concatenated .wav file in goldwave, played and saved the file and then reopened the same file again, the attributes would change to PCM signed, 16 bit little endian, mono.

Q. How do I prevent goldwave from changing the file attributes???

Thanks.

cdeamaze
Posts: 87
Joined: Thu Oct 05, 2006 3:19 pm

file formats

Post by cdeamaze »

file saved as big endian, reopened the same file again, the attributes would change to little endian.

Q. How do I prevent goldwave from changing the file attributes???
Ans. You can't prevent goldwave from changing the file attributes, this is a software issue. As such, the job belongs to Chris and his team :D . Instead, you may consider a solution to your problem such as

When prompted, change your attribute back to big endian.
Otherwise, your music will become noise!

Here is a useful reminder:
Q: How do you know if you save your file as little endian or big endian if you have many files or after a while, you may not remember?
Ans: Append "le" in your file name for little endian and "be" in your file name for big endian. That way, you know exactly how to respond to a prompt for attribute.

Similarly problem arises when:
file saved as little endian, reopened the same file again, the attributes would change to big endian

The same trick can solve the problem:
When prompted, change your attribute back to little endian.
______________________________________________________
A little background on Little-endian versus Big-endian
When more than one byte is required for each sample, the order in which the bytes are stored can vary from system to system. Little-endian files have the least significant byte first, while big-endian files have the most significant byte first. Systems with Intel processors (0x86 & Pentium PCs) and new Macs store bytes in a little-endian order. Systems with Motorola processors (including old Macs), IBM System/370, Sun Sparc store the bytes in big-endian order.

GoldWave Inc.
Site Admin
Posts: 4014
Joined: Wed Mar 10, 2004 6:43 pm
Location: St. John's, NL
Contact:

Re: file formats

Post by GoldWave Inc. »

I don't think GoldWave is changing the attributes.

There are several places where you can set file formats. Under Options | File Formats, there is the "Default Save Format" tab and the "Undetectable Types" tab. Make sure any settings under those tabs match. When saving the file, make sure the attributes selected are the ones you need. When opening the file, if you see the File Format window, again make sure you select the ones you need.

Using a file extension associated with an established audio format (wav) generally is not a good idea.

Chris

Post Reply