Problem with Command Line Recording

GoldWave general discussions and community help
Post Reply
Posts: 5
Joined: Mon Sep 13, 2010 10:09 pm

Problem with Command Line Recording

Post by glieb »

I am trying to get Golwave to start up and begin recording a church service without operator intervention, then save the file at the conclusion and shut down. I can launch from the command line with this shortcut:

"C:\Program Files\GoldWave\GoldWave.exe" -new "C:\My Music\Church Service.wav" -record

Then I use Timer Recording to start at the beginning of my church service with Auto Save and Power Down system.

The problem with this is that it prompts me for a file name because auto save is enabled. As in the above example, I have attempted to give it a filename in the command line, but it seems to be ignored, and still halts waiting for a filename. How do I eliminate the filename prompt?
GoldWave Inc.
Site Admin
Posts: 4061
Joined: Wed Mar 10, 2004 6:43 pm
Location: St. John's, NL

Re: Problem with Command Line Recording

Post by GoldWave Inc. »

You'll need to create the "C:\My Music\Church Service.wav" file first. You'd create a new, blank file with the length of time you want to record, then save that using the filename.

Also make sure the "Auto save" option is checked in Control Properties (press the F11 key) under the Record tab.

The command line to use is:

Code: Select all

"C:\Program Files\GoldWave\GoldWave.exe" "C:\My Music\Church Service.wav" -record -close
That will open the blank file, record into it until the file is full, save the file, then close GoldWave.

Post Reply