Keyboard Sounds

GoldWave general discussions and community help
Post Reply
dwpenn
Posts: 7
Joined: Sun Sep 26, 2004 11:15 pm

Keyboard Sounds

Post by dwpenn » Thu Oct 26, 2017 4:30 pm

I have set Windows 10 Pro Keyboard sounds to NONE.

I like to do other things while a recording is in progress, but if I copy, cut, or paste there are sounds made by the system and they get into the recording.

Because I have silenced Windows and have no other sound source I know of running, I assume these sounds are a part of Goldwave BUT that seems so unlikely that Goldwave's developer would allow his program to intrude on a recording in progress.


If it's Goldwave, how do I shut it off?
If it's not Goldwave, how do I ferret out where it's coming from, or otherwise block it from getting into a recording?
Dean Pennington

raygrote
Posts: 14
Joined: Tue Aug 27, 2013 12:04 am

Re: Keyboard Sounds

Post by raygrote » Thu Oct 26, 2017 4:50 pm

Firstly, what audio device is Gold Wave recording from? And I'm not sure exactly what sounds you're talking about; Gold Wave only records the sounds it receives, it doesn't add any extras. I'd be interested to hear the sounds you're talking about since then perhaps I could get a better idea of where they're coming from. If you've turned sounds off elsewhere, Gold Wave should not just telepathically record them. IF it does, then something is set up wrong but I can't tell you right now what that is, since I don't know how things are set up on your end.

DougDbug
Posts: 2032
Joined: Wed Feb 16, 2005 3:33 pm
Location: Silicon Valley

Re: Keyboard Sounds

Post by DougDbug » Thu Oct 26, 2017 5:20 pm

Right-click on the Windows speaker/volume icon and select Sounds or go to the Windows Control Panel and select Sound. Then click the sounds tab and select No Sounds as your Sound Scheme.

That's only necessary if you're recording streaming audio (or whatever is coming out of your computer speakers/headphones). If you're recording from line-in you'll only get line-in and no system sounds. If you're recording from a microphone you should have the speakers turned-off to prevent feedback/echo (or you should be using headphones) so the mic shouldn't pick up system sounds..

And... It's generally a bad idea to do other stuff while recording. "Multitasking" can interrupt the audio data stream and you can get glitches.

raygrote
Posts: 14
Joined: Tue Aug 27, 2013 12:04 am

Re: Keyboard Sounds

Post by raygrote » Thu Oct 26, 2017 6:19 pm

Slightly off topic, but this reminds me of a problem I'm having. I'm on Win10 BTW.
IF I'm recording, say, streaming audio, normally I will turn my system sounds down in the volume mixer, because I'm sometimes a bit stupid and don't realize that you can change the sound scheme, so thanks for reminding me :). Anyway, when I turn system sounds down, I still hear a sound if something like Dropbox pops up a toast notification, so I have to either turn those off or close programs that could pop up such notifications while recording. Would changing the sound scheme fix this, or is this sound separate somehow? It's starting to get irritating.

dwpenn
Posts: 7
Joined: Sun Sep 26, 2004 11:15 pm

Re: Keyboard Sounds

Post by dwpenn » Thu Oct 26, 2017 6:26 pm

Thanks for the replies. I'll try to respond.

I don't see the capability offered in view now, but if I can I will paste a copy of those sounds to the post.

My sounds are recording from "Loop Back Speakers (USB device)" Indeed it is an externally plugged USB device that outputs the sound to a mini-jack that goes on to an external amplifier and speakers.

[*]Off Topic a bit FYI: The motherboard sound electronics malfunctioned and was sending noise via Ethernet to my router and that noise in turn slowed my internet speed by forcing my ISP to resend packets and so the motherboard sound function was long ago disabled in the BIOS settings and was replaced by the USB.

This Loopback USB listening device and Microphone (also handled by the USB) are the only choices for this PC The USB offers up all sounds the PC makes, offers, or passes through.

[*]On my activity I was doing small cut-n-pastes of text which didn't appear to affect timing of this i7 Intel processor, and Goldwave is told it has maximum priority for recording. So, my extra work hasn't messed up any recordings except where my keyboarding invokes sounds I do not want.

As stated in original post System sounds are set to "none" and that was verified
Dean Pennington

dwpenn
Posts: 7
Joined: Sun Sep 26, 2004 11:15 pm

Re: Keyboard Sounds

Post by dwpenn » Thu Oct 26, 2017 6:28 pm

I'm sorry, I created a small mp3 of the cut-n-paste sounds but do not see where attachments are supported in any format.
Dean Pennington

dwpenn
Posts: 7
Joined: Sun Sep 26, 2004 11:15 pm

Re: Keyboard Sounds

Post by dwpenn » Thu Oct 26, 2017 6:41 pm

raygrote wrote: Would changing the sound scheme fix this, or is this sound separate somehow? It's starting to get irritating.
I assume when I have Windows Sounds set to NONE in response to all the possible sounds in the primary sound Windows 10 setting window that no scheme is invoked.

I have no other applications I know of running that would annunciate cut-n-paste which gets me to the other way of approaching this that I hinted at. I'll ask another way for an alternative solution. Is there a method to identify in the Registry or wherever, what sound is assigned, for example to "paste?" If nothing else I'd either delete that sound file or replace it with a same named file that is devoid of sound.

Could these most basic functions of windows (cut-n-paste) have their sounds built into the native Operating System? Wow, if Microsoft did that, what's the point of me being able to say NONE to System sounds?
Dean Pennington

DewDude420
Posts: 1164
Joined: Fri Mar 11, 2005 11:15 pm
Location: Washington DC Metro Area
Contact:

Re: Keyboard Sounds

Post by DewDude420 » Sun Nov 05, 2017 12:37 pm

I just installed Windows 10 a couple of weeks ago and I haven't had time to change any of the default sound schemes.

I have not heard any kind of copy/paste sound from Windows at all. So Windows is not generating it.

This doesn't leave out other programs in the operating system that might be doing this. I mean...this sounds very strange and my first instinct is an entirely different problem that shouldn't show up when using Loopback to start with.

I assume your PC does have some other kind of onboard sound it uses. If you change the default device, does the sound move devices (provided you can listen to the second one)? That would be the first place I start; of course, I also technically have three different sound devices on my Windows 10 PC to pick from.

The next thing to check is your volume mixer. If any program running initializes the sound using any other method than ASIO or WASAPI Exclusive (which is most things unless you specifically configure it); then you will see it's activity in volume mixer. This will clue you in to what's making this sound...or at the very least; let you mute it there.

Anything beyond that I'm kind of lost. I don't know what USB device you have so I can't go looking at the drivers for it.

I have heard noise from a sound device that manifests itself as a "digital" like garbage sound; but that's an analog issue from ground loop...which is why I say it shouldn't be possible to get that through the USB Loopback.

Post Reply