preventing fade-ins with Wasapi, especially in Gold Wave

GoldWave general discussions and community help
Post Reply
raygrote
Posts: 14
Joined: Tue Aug 27, 2013 12:04 am

preventing fade-ins with Wasapi, especially in Gold Wave

Post by raygrote » Thu Jan 18, 2018 11:52 pm

Hi all,
Two weeks ago, I finally updated my computer from Windows 10 version 1607 to 1709. Things have mostly been fine, except for one thing. With several applications, when I start playing audio, there is a very small fade-in. One of the applications affected by this is Gold Wave. These fade-ins prevent me from hearing if there is a click or not at my start marker. This is unacceptable because I am blind and can't use visual aids to get to 0-crossing points, and don't want to rely on an autosnap feature. I tried using alternative initialization and changing the latency in Gold Wave, and changing my sampling rate and bit depth under Windows advanced sound settings, to no avail. The start of playback is always faded in slightly, just enough so that any click that might be there is inaudible. For now, I have to switch Gold Wave to Direct Sound instead of core audio/Wasapi. This works mostly fine, though I can't use things like loopback for recording until I change the system back to Wasapi. The silver lining here is that the system switching is pretty painless. Just press f11, change it, press OK and it's done.

At first, I thought this fading thing was caused by an update to a Realtech driver. But a friend who doesn't have a Realtech and who is equally affected by the fades is having the same experience since updating to 1709 with me, and was able to reproduce the behavior on my system exactly. On a plug-and-play USB sound card, I get the same results, so I doubt this is a sound card driver issue.

Before posting this thread, I decided to test some things to learn more about the fades. TO do this, I used a cosine wave in Gold Wave's expression evaluator, which afaik starts at a complete opposite of 0 crossing so produces the loudest audible click that could be possible. With Direct Sound, I heard clicks when I started playback, but with Wasapi I did not. When I stopped playback, I would often hear clicks, though there was one specific case where I didn't despite multiple attempts, and I can't for the life of me figure out why. But that was only one specific case that I've been unable to reproduce since.

Adding silence to the beginning of the file, no matter how short, stopped the fades completely and allowed me to hear the clicks again. A single sample of silence is really all it took. Lowering the volume by a dramatic amount also made the click audible, though extremely quiet since I had to lower the volume by about -50dB. So my theory is that, when the audio stream is opened, if the value of the first sample is greater than a certain point, a fade will happen, and if it isn't, the fade will be bypassed.

So far Gold Wave has been the only program I have tested that can use Wasapi and Direct Sound. While I believe I hear fades in other programs, they are often so short that I ignore them, so Gold Wave is the only program in which I consider this a major problem. I have not tested in any other audio applications though I plan to do so in the near future.

I am pretty convinced that somewhere between 1607 and 1709, Wasapi was changed in some way. In addition, I also think that fades are process-dependent, so playing a low-level signal in an attempt to keep the device open and avoid the need for a fade-in would only serve to keep a process's audio open, and not the entire sound system. I could be wrong about this, though, but I wouldn't be surprised, given the fact that Windows is able to separate the audio of different programs.

Despite being convinced that an update was responsible for this behavior and isn't sound card or program specific, I'm still posting this to the Gold Wave forums because it affects me most when using Gold Wave, and I hope that at least one or two other people have noticed this behavior and may possibly be a step ahead of me in research to figure out why this happens, and maybe how to disable it. I really don't know where else to post this. If anyone has ideas, even if it's just another board to post this on, please let me know.

Thanks for reading!

BillK
Posts: 31
Joined: Thu Apr 01, 2004 5:53 pm
Location: East Coast of Nebraska

Re: preventing fade-ins with Wasapi, especially in Gold Wave

Post by BillK » Fri Jan 19, 2018 2:14 pm

I believe that you are totally correct about the fade in (and out) for Windows 10 1709. It is documented on the Micro$oft website. They say to install (re-install) your audio driver in Compatibility Mode. I guess that means your Realtech.. ??? I do not use Realtech for my driver. AND - I am still on 1607 - - because Micro$oft is still "working" on a problem for me to get my PC to take the update to 1709.

But, you might just Google the term 'Windows 10 version 1709 Audio fade in' and you should find references.

raygrote
Posts: 14
Joined: Tue Aug 27, 2013 12:04 am

Re: preventing fade-ins with Wasapi, especially in Gold Wave

Post by raygrote » Sun Jan 21, 2018 12:50 am

I recently did a similar search as you suggested and couldn't find anything.

What confuses me is that this doesn't just happen with Realtech cards. It happens with plug-and-play devices, and also with a friend's computer which doesn't have Realtech. I even updated my laptop yesterday from 1607 to 1709. I reinstalled Windows on it last week, and never installed any sound drivers on it other than the generic Microsoft HD audio that Windows puts on it. On 1607, I confirmed that Wasapi didn't fade, but when updating to 1709, it did. That laptop doesn't have a Realtech either.

Are you perhaps suggesting the generic Microsoft HD audio drivers are at fault and I should somehow reinstall those in compatibility mode? I don't know if that's possible, but if it is, maybe that's what I have to do?

BillK
Posts: 31
Joined: Thu Apr 01, 2004 5:53 pm
Location: East Coast of Nebraska

Re: preventing fade-ins with Wasapi, especially in Gold Wave

Post by BillK » Sun Jan 21, 2018 6:25 pm

When I searched for that EXACT string I gave you ([b]Windows 10 version 1709 Audio fade in[/b]), here is the first link:
https://answers.microsoft.com/en-us/win ... bfd?auth=1

In clicking on some of the links given in that post, I also find this from Microsoft:
https://support.microsoft.com/en-us/hel ... #v1h=tab01

None of these specifically say Realtech either. They simply say "update your audio DRIVER". The first link above are postings from Micro$oft customers who have experienced problems. The second post is from Micro$oft explaining a (possible) fix.

Unfortunately for us, when Micro$oft breaks things with their forced updates, they just don't care anymore if the problems they cause affects a small percentage of people. It's just not the same Micro$oft that was around when Windows 7 was most popular. (Maybe it still is).

GoldWave Inc.
Site Admin
Posts: 3897
Joined: Wed Mar 10, 2004 6:43 pm
Location: St. John's, NL
Contact:

Re: preventing fade-ins with Wasapi, especially in Gold Wave

Post by GoldWave Inc. » Mon Jan 22, 2018 10:35 am

In GoldWave, use Options | Control Properties, select the Device tab, then change the playback Quality to 16 bit (or 24 bit if supported). That gives GoldWave more control over the device and should avoid the shared stream fading.

Post Reply