Equalizer doesn't like mp3

GoldWave general discussions and community help
Post Reply
Kummel
Posts: 141
Joined: Sat Sep 23, 2006 7:10 pm

Equalizer doesn't like mp3

Post by Kummel »

Windows XP servicepack 3, just moved from GOldwave 5.25 to 5.52

When I try to apply the equalizer in an mp3, the peak level is about 2500:1 (what would do around +68 dB, but Goldwave doesn't convert), and the window is completely full of the envelope.
After adjustment at a 0dB peak level, there is a 11 kHz sine instead of the sound.

If I process exactly the same sound, but in a wave file, the equalizer works normally.

If I have a wave file, and save it as mp3, I can process the equalizer normally. But if I close and re-open this mp3, the equalizer does'nt work no more.
:D

DougDbug
Posts: 2067
Joined: Wed Feb 16, 2005 3:33 pm
Location: Silicon Valley

Post by DougDbug »

Since GoldWave decodes/converts everything to 32-bit floating-point PCM whenever you open a file, this is most likely a problem with the MP3 encoder or decoder. Did you download a new copy of LAME when you installed 5.52?

DewDude420
Posts: 1164
Joined: Fri Mar 11, 2005 11:15 pm
Location: Washington DC Metro Area
Contact:

Post by DewDude420 »

works just fine here. i'm not sure what that could be....i've had some bizarre things happen that were isolated incidents...but never anything like that.

Kummel
Posts: 141
Joined: Sat Sep 23, 2006 7:10 pm

Post by Kummel »

I just reinstalled the LAME 3.98 encod dll, and it still does it. I add that the mp3 files open and save with no problem, it's only the equalizer that doesn't work when the sound has been opened from a mp3, and whatever be how much operations have been made before.
:D

GoldWave Inc.
Site Admin
Posts: 4017
Joined: Wed Mar 10, 2004 6:43 pm
Location: St. John's, NL
Contact:

Re: Equalizer doesn't like mp3

Post by GoldWave Inc. »

The MP3 may contain data that is causing the floating point processor to get into a bad state. Having the "Ignore floating point errors" boxed checked under Start | All Programs | GoldWave | GoldWave Setup could cause problems with the Equalizer effect.

Chris

Kummel
Posts: 141
Joined: Sat Sep 23, 2006 7:10 pm

Post by Kummel »

The problem seems not to occur anymore, but I uninstalled/reinstalled both Goldwave and K-Lite Codec. Only files who get an illustration embedded from iTunes have some trouble, for opening, if I just remove all tags prior to open, it works fine.
:D

Post Reply