Recording sound card output

GoldWave general discussions and community help
Post Reply
Posts: 1
Joined: Sat Apr 17, 2010 8:10 pm

Recording sound card output

Post by club »

In the recording options, on the Volume tab, where you can check the box for which recording input to use (microphone, line-in, etc) I used to have an option of "Stereo mix" at the top. Choosing this would cause Goldwave to record whatever was being outputted to my speakers by my sound card. I loved having this feature for various reasons.

Than I got Windows7. My Soundblaster sound card wouldnt work with it. Apparently it was just old enough that it has no 7 drivers. I went Creative Lab's site and went to the driver downloads section for this specific card, and sure enough, XP was the most recent OS option listed.

Ok, so I buy a new cheap SoundBlaster card that I make sure does support 7. I install it and it works, yay. BUT, now when goes into Goldwave, on that Volume tab, I no longer have "Stereo mix". It's now been replaced with S/PDIF-In. But choosing this, or any of the other inputs, does not record my sound card's output. :( This sucks.

Is this just a functionality of whatever soundcard you have? Do I need to get another sound card if I want to have this ability again?

Posts: 327
Joined: Sat May 15, 2004 7:29 pm
Location: Fallentown, PA

Re: Recording sound card output

Post by Stiiv »

First thing you should do:

Open the Windows volume control (little speaker in the system tray), choose Options/Properties, select Recording, & see which sources are checked; any box not checked won't show up as an available recording source.

Hope this helps.

Posts: 2065
Joined: Wed Feb 16, 2005 3:33 pm
Location: Silicon Valley

Re: Recording sound card output

Post by DougDbug »

If your driver and hardware don't support it, you might need to use a loopback cable from line-out to line-in. (See the GoldWave FAQ here and here.)

I also found some information here.

Post Reply