video files won't load with ffmpeg libraries installed.

VideoMeld discussions and community help
Post Reply
cameramandan
Posts: 5
Joined: Thu May 15, 2014 8:30 pm

video files won't load with ffmpeg libraries installed.

Post by cameramandan »

I am currently trying to test Videomeld but can't seem to get mpeg2 or vob files to load on to the video track. Mp4 files load fine. I'm sure I have properly configured the directory containing the ffmpeg libraries and have confirmed that the required libraries are there. Now I am stumped. I plan to buy the license if I can get past this obstacle. Any ideas?
GoldWave Inc.
Site Admin
Posts: 4087
Joined: Wed Mar 10, 2004 6:43 pm
Location: St. John's, NL
Contact:

Re: video files won't load with ffmpeg libraries installed.

Post by GoldWave Inc. »

What version of the ffmpeg binaries did you install? You'd need 2.1 or one of the libav builds from November of last year should work too. Note that copy protected VOB files can't be opened.

Chris
cameramandan
Posts: 5
Joined: Thu May 15, 2014 8:30 pm

Re: video files won't load with ffmpeg libraries installed.

Post by cameramandan »

This is what I have in the target directory:
avcodec-55 version 55.60.103.0
avdevice-55 version 55.13.101.0
avfilter-4 version 4.5.100.0
avformat-55 version 55.37.102.0
avutil-52 version 52.81.100.0
postproc-52 version 52.3.100.0
swscale-2 version 2.6.100.0
swresample-0 version 0.18.100.0

....plus the following .exe files
ffmpeg
ffplay
ffprobe

I believe these are all the latest libraries from the FFmpeg website.

Also, the .vobs are self produced non-copywrited files.
GoldWave Inc.
Site Admin
Posts: 4087
Joined: Wed Mar 10, 2004 6:43 pm
Location: St. John's, NL
Contact:

Re: video files won't load with ffmpeg libraries installed.

Post by GoldWave Inc. »

If you create a test project and use File | Meld Project To Video File does WebM show up as a file type you can select? That would indicate that the ffmpeg/libav decoders and encoders are recognized by VideoMeld.

Does the VOB file play normally in other software? What happens when you try to add the VOB file to VideoMeld? Do you get an error, or just an audio track?

Chris
cameramandan
Posts: 5
Joined: Thu May 15, 2014 8:30 pm

Re: video files won't load with ffmpeg libraries installed.

Post by cameramandan »

Hi Chris,
Ok here's what I have so far...
I loaded a test video file (the Wildlife sample video file in Win7)
and then saved it as a test project without doing anything to the file itself.

Then, as you indicated, I chose File | Meld Project To Video File
The only options that came up were mpeg4 (H.264) and Windows media video.

The .vob I mentioned earlier plays fine in other software.
Adding it to a video track just gives an error
"Cannot open video in file".

I am inclined to think Videomeld just isn't recognizing the FFmpeg libs but can't figure out why.
BTW, I used the directory path C:\FFmpeg to keep things simple and even rebooted the machine.
No luck.
cameramandan
Posts: 5
Joined: Thu May 15, 2014 8:30 pm

Re: video files won't load with ffmpeg libraries installed.

Post by cameramandan »

Would someone be kind enough to tell me what codec (ffmpeg or libav) file versions they are using and how they have Videomeld set up to use them? It's been many weeks since my first post above and I have not been able to get VM to work with anything other than mp4 video clips and jpg files. I undertand why Chris can't walk me thru the setup process or post a link to the files but maybe someone else can. (I thought I had found a Videomeld setup tutorial on You Tube about this, but it's in a language I don't understand). Also, the exact link as to where to get the correct files. I found this part VERY confusing as there seemed to be countless files on the Zeranoe FFMPEG site and no real understandable explanation as to exactly what they are and which one to choose, ie shared and static.... I am a video editor - not a computer programmer. ALSO, the Zeranoe FFmpeg website (http://ffmpeg.zeranoe.com/builds/) has this odd comment: "If you are confused about what download you need, just download the 32-bit static builds." ....? Well Hey I have a 64bit machine....!?

MY CONFIG: Windows 7 Home Premium 64bit, Gateway FX6840 motherboard 8 core I7 CPU, 8gb ram.

Thank you for any clarification on this. It would be great if someone could do a Videomeld SET UP tutorial in plain English.


cameramandan wrote:Hi Chris,
Ok here's what I have so far...
I loaded a test video file (the Wildlife sample video file in Win7)
and then saved it as a test project without doing anything to the file itself.

Then, as you indicated, I chose File | Meld Project To Video File
The only options that came up were mpeg4 (H.264) and Windows media video.

The .vob I mentioned earlier plays fine in other software.
Adding it to a video track just gives an error
"Cannot open video in file".

I am inclined to think Videomeld just isn't recognizing the FFmpeg libs but can't figure out why.
BTW, I used the directory path C:\FFmpeg to keep things simple and even rebooted the machine.
No luck.
GoldWave Inc.
Site Admin
Posts: 4087
Joined: Wed Mar 10, 2004 6:43 pm
Location: St. John's, NL
Contact:

Re: video files won't load with ffmpeg libraries installed.

Post by GoldWave Inc. »

VideoMeld is a 32 bit program, so you'll need 32 bit versions of the ffmpeg or libav modules (even on 64 bit versions of Windows). One of the 7z packages on the libav Win32 download site from late November should work. Disclaimer: all legal aspects of installing and using such modules are the responsibility of the end user.

Chris
cameramandan
Posts: 5
Joined: Thu May 15, 2014 8:30 pm

Re: video files won't load with ffmpeg libraries installed.

Post by cameramandan »

Thanks Chris, but I couldn't find the required dll files there. Went back to Zeranoe site and tried the 32 bit shared files and it looks like it's working now. I thought I had to use the 64bit files since I have a 64bit machine. Thanks.
Post Reply